
	
		

<!doctype html>

<!--[if lt IE 7]><html lang="en-US" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <!--<![endif]-->

	<head>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
	<meta charset="utf-8">
	<meta name="HandheldFriendly" content="True">
	<meta name="MobileOptimized" content="320">
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0"/>
	<link rel="pingback" href="http://www.vh1.com/news/xmlrpc.php">

	
	<title>
		You Need to Hear the Mariachi Version of 'Gin and Juice' i - VH1			</title>

	<link rel="canonical" href="http://www.vh1.com/news/336057/martha-snoop-gin-and-juice-bonus-clip/" />



<link rel='dns-prefetch' href='//www.vh1.com' />
<link rel='dns-prefetch' href='//btg.mtvnservices.com' />
<link rel='dns-prefetch' href='//media.mtvnservices.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='mtvn.wordpress.plugins.MTVNMediaPlayer-css'  href='http://www.vh1.com/news/wp-content/plugins/MTVNMediaPlayer/css/media_player.css' type='text/css' media='' />
<link rel='stylesheet' id='vex-custom-css'  href='http://www.vh1.com/news/wp-content/plugins/AOCore/css/vex.custom.css' type='text/css' media='all' />
<link rel='stylesheet' id='css-on-flipbook-css'  href='http://www.vh1.com/news/wp-content/plugins/AOFlipbookViewer/css/flipbook.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-geg-nav-js-css'  href='http://www.vh1.com/news/wp-content/plugins/GEGNav/css/GEGNav.css' type='text/css' media='all' />
<link rel='stylesheet' id='news-stylesheet-css'  href='http://www.vh1.com/news/wp-content/plugins/VH1News/css/style.css' type='text/css' media='all' />
<link rel='https://api.w.org/' href='http://www.vh1.com/news/wp-json/' />
<link rel="canonical" href="http://www.vh1.com/news/336057/martha-snoop-gin-and-juice-bonus-clip/" />
<link rel="alternate" type="application/json+oembed" href="http://www.vh1.com/news/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.vh1.com%2Fnews%2F336057%2Fmartha-snoop-gin-and-juice-bonus-clip%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.vh1.com/news/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.vh1.com%2Fnews%2F336057%2Fmartha-snoop-gin-and-juice-bonus-clip%2F&#038;format=xml" />
<link rel="shortcut icon" href="http://www.vh1.com/favicon.ico" />
<link rel="stylesheet" href="http://fonts.mtvnservices.com/k/gdr2jlq-d.css?3bb2a6e53c9684ffdc9a9bf61f5b2a62850218b0182b3a8f955d7a9c9c604db9d18d97713afebddbdef2f1611bc74f5a4a7903b65883d37fbe7ef455f73ef5670639f8bf4f14398efd7dda62af5d0334085d329d13149b3e688083e3766591f3c813ad483cb22c42a0"/>
<script type="text/javascript" src="http://fonts.mtvnservices.com/tts3nhd.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){};</script>
<script type='text/javascript'>
if (typeof MTVN == 'undefined') MTVN = {};
if (typeof MTVN.config == 'undefined') MTVN.config = {};
if (typeof MTVN.config.btg == 'undefined') MTVN.config.btg = {};
if (typeof MTVN.config.btg.Flux == 'undefined') MTVN.config.btg.Flux = {};
MTVN.config.btg.Flux.enabled = false;
</script><meta property="reporting:beacon_url" content="http://mb.mtvnservices.com/data/collect/v1/mb.gif">
<meta property="reporting:beacon_topic" content="vh1.com">
<meta property="ao:mgid" content="mgid:wordpress:post:articles.vh1.com:336057">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","url":"http:\/\/www.vh1.com\/news\/336057\/martha-snoop-gin-and-juice-bonus-clip\/","headline":"You Need to Hear the Mariachi Version of &#8220;Gin and Juice&#8221; in This <em>Martha &#038; Snoop<\/em> Bonus Clip","thumbnailUrl":"http:\/\/imagesvh1-a.akamaihd.net\/uri\/mgid:ao:image:vh1.com:258912?quality=0.8&format=jpg","dateCreated":"2017-12-01T16:36:28+00:00","articleSection":"Shows","creator":"Andrea Wurzburger","keywords":["Martha &amp; Snoop's Potluck Dinner Party"]}</script>


		
	<div class="nav" style="display:none;"><ul><li><a href="http://www.vh1.com/shows">Shows</a><ul><li><a href="http://www.vh1.com/full-episodes">Full Episodes</a></li><li><a href="http://www.vh1.com/shows">Shows A-Z</a></li><li><a href="http://www.vh1.com/tv-schedule">TV Schedule</a></li><li><a href="http://www.vh1.com/shows/love-and-hip-hop">Love & Hip Hop</a></li><li><a href="http://www.vh1.com/shows/scared-famous">Scared Famous</a></li><li><a href="http://www.vh1.com/shows/black-ink-crew">Black Ink Crew</a></li><li><a href="http://www.vh1.com/shows/black-ink-crew-chicago">Black Ink Crew Chicago</a></li><li><a href="http://www.vh1.com/shows/rupauls-drag-race-all-stars">RuPaul's Drag Race All Stars</a></li><li><a href="http://www.vh1.com/shows/martha-snoops-potluck-dinner-party">Martha & Snoop's Potluck Dinner Party</a></li><li><a href="http://www.vh1.com/shows/love-and-hip-hop-miami">Love & Hip Hop Miami</a></li><li><a href="http://www.vh1.com/shows/hip-hop-squares">Hip Hop Squares</a></li><li><a href="http://www.vh1.com/shows/brunch-with-tiffany">Brunch With Tiffany</a></li></ul></li><li><a href="http://www.vh1.com/news/">News</a></li><li><a href="http://www.vh1.com/shows/digital-originals">Digital Originals</a></li><li><a href="http://www.vh1.com/live-tv">Watch Live TV</a></li></ul></div>

	<script type="application/json" id="site-nav-object">
	{"envelope":{"version":"1.0","name":"entertainment-standard-json"},"status":{"text":"OK","code":100},"result":{"promo":{"shortId":"49xbos","displayType":"default","promoType":"ENT_M066","headline":"","images":[],"subHeadline":"","url":"","additionalPromoMetadata":[],"copy":"","tuneIn":"","parameters":[],"links":[]},"siteNavigation":[{"title":"Shows","url":"http:\/\/www.vh1.com\/shows","entries":[{"title":"Full Episodes","url":"http:\/\/www.vh1.com\/full-episodes"},{"title":"Shows A-Z","url":"http:\/\/www.vh1.com\/shows"},{"title":"TV Schedule","url":"http:\/\/www.vh1.com\/tv-schedule"},{"title":"Love & Hip Hop","url":"http:\/\/www.vh1.com\/shows\/love-and-hip-hop"},{"title":"Scared Famous","url":"http:\/\/www.vh1.com\/shows\/scared-famous"},{"title":"Black Ink Crew","url":"http:\/\/www.vh1.com\/shows\/black-ink-crew"},{"title":"Black Ink Crew Chicago","url":"http:\/\/www.vh1.com\/shows\/black-ink-crew-chicago"},{"title":"RuPaul's Drag Race All Stars","url":"http:\/\/www.vh1.com\/shows\/rupauls-drag-race-all-stars"},{"title":"Martha & Snoop's Potluck Dinner Party","url":"http:\/\/www.vh1.com\/shows\/martha-snoops-potluck-dinner-party"},{"title":"Love & Hip Hop Miami","url":"http:\/\/www.vh1.com\/shows\/love-and-hip-hop-miami"},{"title":"Hip Hop Squares","url":"http:\/\/www.vh1.com\/shows\/hip-hop-squares"},{"title":"Brunch With Tiffany","url":"http:\/\/www.vh1.com\/shows\/brunch-with-tiffany"}]},{"title":"News","url":"http:\/\/www.vh1.com\/news\/"},{"title":"Digital Originals","url":"http:\/\/www.vh1.com\/shows\/digital-originals"},{"title":"Watch Live TV","url":"http:\/\/www.vh1.com\/live-tv"}],"socialHandlers":{"facebook":"http:\/\/www.facebook.com\/VH1","twitter":"https:\/\/twitter.com\/VH1","tumblr":"http:\/\/vh1.tumblr.com\/"},"search":{"url":"","data":""}},"messages":{}}	</script>

	<script type="application/json" id="site-nav-vars">
	{"nav_site_name":"VH1 Home","nav_site_url":"http:\/\/www.vh1.com\/"}	</script>

		


			<meta property="og:site_name" content="VH1 News">
				<meta property="og:title" content="You Need to Hear the Mariachi Version of &quot;Gin and Juice&quot; in This Martha &amp; Snoop Bonus Clip">
				<meta property="og:url" content="http://www.vh1.com/news/336057/martha-snoop-gin-and-juice-bonus-clip/">
				<meta property="og:image" content="http://imagesvh1-a.akamaihd.net/uri/mgid:ao:image:vh1.com:258912?quality=0.8&amp;format=jpg&amp;width=1440&amp;height=810&amp;.jpg">
				<meta property="og:type" content="article">
				<meta property="og:description" content="One, two, three and to the four...it&#039;s &quot;Gin And Juice&quot; like you&#039;ve never heard it before. ">
				<meta property="sm4:author" content="Andrea Wurzburger">
				<meta property="sm4:type" content="Post">
				<meta property="og:image:width" content="1440">
				<meta property="og:image:height" content="810">
				<meta property="fb:app_id" content="709094809266522">
	
<meta name="mtvn_ct" content="blog"/>

	<meta name="mtvn_title" content="You Need to Hear the Mariachi Version of &#039;Gin and Juice&#039; i - VH1"/>

	<meta name="mtvn_desc" content="On Martha &amp; Snoop&#039;s Potluck Dinner Party, the mariachi band plays &#039;Gin and Juice&#039; for Snoop."/>
	<meta name="mtvn_date" content="2017-12-01:16-36"/>





			<meta name="twitter:description" content="On Martha &amp; Snoop&#039;s Potluck Dinner Party, the mariachi band plays &#039;Gin and Juice&#039; for Snoop.">
				<meta name="twitter:title" content="You Need to Hear the Mariachi Version of &#8220;Gin and Juice&#8221; in This Martha &#038; Snoop Bonus Clip">
				<meta name="twitter:image" content="http://imagesvh1-a.akamaihd.net/uri/mgid:ao:image:vh1.com:258912?quality=0.8&amp;format=jpg&amp;width=500&amp;height=375">
				<meta name="twitter:url" content="http://www.vh1.com/news/336057/martha-snoop-gin-and-juice-bonus-clip/">
				<meta name="twitter:card" content="summary_large_image">
	<script type='text/javascript'>var _sf_startpt=(new Date()).getTime();</script>
			<meta name="description" content="On Martha &amp; Snoop&#039;s Potluck Dinner Party, the mariachi band plays &#039;Gin and Juice&#039; for Snoop." />
				<meta name="thumbnail" content="http://imagesvh1-a.akamaihd.net/uri/mgid:file:http:shared:vh1.com/news/wp-content/uploads/2017/12/Screen-Shot-2017-12-01-at-4.17.23-PM-1512163065-300x133.png?quality=0.8&amp;format=jpg" />
	
	</head>

	<body class="post-template-default single single-post postid-336057 single-format-standard tax-series-martha-snoops-potluck-dinner-party">
		<div id="page_root">

			<div id="fb-root"></div>

			<div class="navbar navbar-fixed-top-not">

		<div id="ad-container">
		<div class="container">
			<div class="ad-banner">
			<div id="1" class="vmn_coda_ad vmn_coda_ad-banner " data-ad-sizes="banner" data-ad-keyvalues="" style="padding:0; text-align:center;">

	
	<noscript>
			</noscript>

</div>


			</div>
		</div>
	</div>
	
	<div id="navbar-inner">
		<div class="site_header wp-ao-geg-nav">
	<div class="top_outer">
		<div class="top_inner">

			<div class="menu_holder">
				<div id="hamburger-holder"></div>

				<div class="site_logo">
					<a href="http://www.vh1.com/">
						<span data-graphics="A" class="icon"></span>
						<span class="screen-reader-text"></span>
					</a>
				</div>

				<div class="page_overlay"></div>
			</div>

			<a href="/" class="show_logo">
				<span class="wrapper"><span class="title sitename"></span></span>
			</a>

		</div>
	</div>
</div>
<h2 class="category archive-title h2">
	<a href="http://www.vh1.com/news/">news</a>
</h2><div class="subnav-wrapper">
	<input type="checkbox" id="subnav-toggler">
	<label class="empty" for="subnav-toggler">
		<span class="icon-chevron-thin-down"></span>
	</label>
	<ul>
			</ul>
</div>
		<div class="container">
						<div id="nav-top">
				<div class="brand pull-left">
					<a class="icon-actions-close" id="nav-close">
						<span class="icon-datas-list"> </span>
					</a>
				</div>
				<a href="http://www.vh1.com/">
				  <span class="icon-logo-mtv icon-logo-brand"></span>
				</a>
				<div class="title">
					<a href="http://www.vh1.com/news/">
						<span class="sitename">
							VH1						</span>
					</a>
									</div>
			</div>
								</div>
	</div>
	<div id="nav-dim"></div>

				
</div>

	<div class="item promo-block lead-image">
    <div class="media">
        <div class="container-lead-image">
            <div class="content">
                <div class="photo" id="">
	<img
		src="http://imagesvh1-a.akamaihd.net/uri/mgid:ao:image:vh1.com:258912?quality=0.8&amp;format=jpg&amp;width=480&amp;height=270"
		srcset="http://imagesvh1-a.akamaihd.net/uri/mgid:ao:image:vh1.com:258912?quality=0.8&amp;format=jpg&amp;width=481&amp;height=270 481w, http://imagesvh1-a.akamaihd.net/uri/mgid:ao:image:vh1.com:258912?quality=0.8&amp;format=jpg&amp;width=660&amp;height=371 660w, http://imagesvh1-a.akamaihd.net/uri/mgid:ao:image:vh1.com:258912?quality=0.8&amp;format=jpg&amp;width=768&amp;height=432 768w, http://imagesvh1-a.akamaihd.net/uri/mgid:ao:image:vh1.com:258912?quality=0.8&amp;format=jpg&amp;width=980&amp;height=551 980w, http://imagesvh1-a.akamaihd.net/uri/mgid:ao:image:vh1.com:258912?quality=0.8&amp;format=jpg&amp;width=1200&amp;height=675 1200w, http://imagesvh1-a.akamaihd.net/uri/mgid:ao:image:vh1.com:258912?quality=0.8&amp;format=jpg&amp;width=1500&amp;height=843 1500w, http://imagesvh1-a.akamaihd.net/uri/mgid:ao:image:vh1.com:258912?quality=0.8&amp;format=jpg&amp;width=1800&amp;height=1012 1800w"
		title=""
		class=" js-srcset-img shortcode-image "
		alt="" />
		<div class="photocredit">
						    					</div>
</div>
                                <!--<img src=""/>-->
            </div>
        </div>
    </div>
    <div class="photocredit">
                    </div>
</div>

<div class="container">
	<div id="content" class="clearfix">
		<div class="row">
			<div id="main" class=" col-sm-12 clearfix" role="main">
			<div class="row">

				
				
				
				
										
					
																		

<article id="post-336057" class="clearfix post-336057 post type-post status-publish format-standard has-post-thumbnail hentry category-shows series-martha-snoops-potluck-dinner-party tax-series-martha-snoops-potluck-dinner-party" role="article">
	<div class="col-md-8 story">

						<div class="category ">
					<a href="http://www.vh1.com/news/shows/" title="View all posts in Shows">Shows</a>			</div>

	<div class="header">
		<h1 class="h1">
			<span class="headline">
										You Need to Hear the Mariachi Version of &#8220;Gin and Juice&#8221; in This <em>Martha &#038; Snoop</em> Bonus Clip						</span>
		</h1>
		<div class="subhead">
			One, two, three and to the four...it's "Gin And Juice" like you've never heard it before. 		</div>
	</div>

	<section class="entry-content clearfix">
		<div class="hr"></div>

					<span class="byline">
  by <span class="author"><a href="http://www.vh1.com/news/author/wurzbura/" title="Posts by Andrea Wurzburger" rel="author">Andrea Wurzburger</a></span>
  <span class="date">
11h ago</span>
</span>
		
		
					<div id="aosocial-widget" data-widget-config="{&quot;facebook&quot;:{&quot;shareText&quot;:&quot;You Need to Hear the Mariachi Version of \&quot;Gin and Juice\&quot; in This Martha &amp; Snoop Bonus Clip&quot;,&quot;tooltip&quot;:&quot;Share to Facebook&quot;,&quot;url&quot;:&quot;http:\/\/www.vh1.com\/news\/336057\/martha-snoop-gin-and-juice-bonus-clip\/?fb_ref=fbshare_web&quot;},&quot;twitter&quot;:{&quot;shareText&quot;:&quot;You Need to Hear the Mariachi Version of \&quot;Gin and Juice\&quot; in This Martha &amp; Snoop Bonus Clip&quot;,&quot;tooltip&quot;:&quot;Tweet to Twitter&quot;,&quot;url&quot;:&quot;http:\/\/www.vh1.com\/news\/336057\/martha-snoop-gin-and-juice-bonus-clip\/?utm=share_twitter&quot;,&quot;via&quot;:&quot;VH1&quot;},&quot;email&quot;:{&quot;shareText&quot;:&quot;VH1 |You Need to Hear the Mariachi Version of \&quot;Gin and Juice\&quot; in This Martha &amp; Snoop Bonus Clip&quot;,&quot;body&quot;:&quot;Check out this post I found on VH1 News: \r\n \r\nhttp:\/\/www.vh1.com\/news\/336057\/martha-snoop-gin-and-juice-bonus-clip\/?xrs=share_copy_email&quot;}}"></div>
		
				<p><div class="deferred_content">
			Embedded from <a href="//media.mtvnservices.com/embed/mgid:arc:video:vh1.com:29baef5d-5c18-4b84-97c5-91839fdf2863">media.mtvnservices.com</a>.
		<noscript class="deferred_content" data-deferred-info="{&quot;type&quot;:&quot;iframe&quot;}">
		<iframe src="//media.mtvnservices.com/embed/mgid:arc:video:vh1.com:29baef5d-5c18-4b84-97c5-91839fdf2863" width="640" height="360" frameborder="0" allowfullscreen="true">	</noscript>
</div></iframe><br />
In case you missed it, this week&#8217;s episode of <em><a href="http://www.vh1.com/shows/martha-snoops-potluck-dinner-party" rel="noopener" target="_blank">Martha &#038; Snoop&#8217;s Potluck Dinner Party</a></em> brought you a Taco Wednesday no one will ever top. The best part? Probably the live mariachi band. In this deleted scene, the band pays a special tribute to <strong>Snoop Dogg</strong>, playing &#8220;Gin and Juice&#8221; like you&#8217;ve never heard it before. </p>
<p>It&#8217;s got Snoop dancing like this:<br />
<div class="deferred_content">
			Embedded from <a href="https://giphy.com/embed/3o6fJgHTPk8Q0JEDV6">giphy.com</a>.
		<noscript class="deferred_content" data-deferred-info="{&quot;type&quot;:&quot;iframe&quot;}">
		<iframe src="https://giphy.com/embed/3o6fJgHTPk8Q0JEDV6" width="480" height="268" frameBorder="0" class="giphy-embed" allowFullScreen>	</noscript>
</div></iframe></p>
<p><a href="https://giphy.com/gifs/3o6fJgHTPk8Q0JEDV6"></a></p>
<p>And like this:<br />
<div class="deferred_content">
			Embedded from <a href="https://giphy.com/embed/3o6fJaPYnCceZbCHZK">giphy.com</a>.
		<noscript class="deferred_content" data-deferred-info="{&quot;type&quot;:&quot;iframe&quot;}">
		<iframe src="https://giphy.com/embed/3o6fJaPYnCceZbCHZK" width="480" height="268" frameBorder="0" class="giphy-embed" allowFullScreen>	</noscript>
</div></iframe></p>
<p><a href="https://giphy.com/gifs/3o6fJaPYnCceZbCHZK"></a></p>
<p>And <strong>George Lopez</strong> was feelin&#8217; it, too!<br />
<div class="deferred_content">
			Embedded from <a href="https://giphy.com/embed/xT0xeBoh7ciNXIMHde">giphy.com</a>.
		<noscript class="deferred_content" data-deferred-info="{&quot;type&quot;:&quot;iframe&quot;}">
		<iframe src="https://giphy.com/embed/xT0xeBoh7ciNXIMHde" width="480" height="268" frameBorder="0" class="giphy-embed" allowFullScreen>	</noscript>
</div></iframe></p>
<p><a href="https://giphy.com/gifs/xT0xeBoh7ciNXIMHde"></a></p>
<p>Hear the mariachi version in the clip above! We bet it&#8217;ll have you dancin&#8217; like Snoop! </p>
<p>Catch up with old episodes of <em><a href="http://www.vh1.com/shows/martha-snoops-potluck-dinner-party" rel="noopener" target="_blank">Martha &#038; Snoop&#8217;s Potluck Dinner Party</a></em> on <a href="http://www.vh1.com/shows/martha-snoops-potluck-dinner-party" rel="noopener" target="_blank">VH1.com </a>and on the VH1 app!</p>
<div class="related_link " >
	<a href="http://www.vh1.com/news/335616/martha-and-snoop-holiday-recipes/">
			<div class="deferred_content">
		<noscript class="deferred_content" data-deferred-info="{&quot;type&quot;:&quot;img&quot;}">
		<img src="http://imagesvh1-a.akamaihd.net/uri/mgid:ao:image:vh1.com:258683?quality=0.8&format=jpg&width=150&height=110">	</noscript>
</div><!-- -->
			<p>
			<span>The Holidays Came Early and Martha & Snoop Are Giving the Gift of Delicious Holiday Recipes</span>
		</p>
	</a>
</div>


					<div class="author">
	
	<div data-src="http://www.vh1.com/news/wp-content/plugins/VH1News/img/default_author.jpg" class="author_crop"></div>

	<div><a href="http://www.vh1.com/news/author/wurzbura/" title="Posts by Andrea Wurzburger" rel="author">Andrea Wurzburger</a></div>

		
		
	
</div>
			</section>

		<script>

	(function(d, s, id) {
		var js,
		    fjs = d.getElementsByTagName(s)[0];

		if (d.getElementById(id)) {
			return;
		}

		js     = d.createElement(s);
		js.id  = id;
		js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.7";

		fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));

</script>

<div class="fb-comments" data-width="100%" data-numposts="2" data-order-by="social" data-href="http://www.vh1.com/news/336057/martha-snoop-gin-and-juice-bonus-clip/"></div>
	
	</div>

	<aside class="sidebar col-md-4 col-sm-12">
		
<ul class="widgets row">
    <div class="col-md-12">
        <li id="coda_ad-2" class="widget CodaAdWidget"><div id="2" class="vmn_coda_ad vmn_coda_ad-tile widget_ad widget_ad_tile" data-ad-sizes="tile" data-ad-keyvalues="" style="padding:0; ">

	
	<noscript>
			</noscript>

</div>


</li>

                        <li class="widget_trending_stories nodata"></li>
            </div>
</ul>
	</aside>

</article>
											
					
				
				
				<nav class="wp-prev-next">
	<ul class="clearfix">
		<noscript>
			<li class="prev-link noscript">
							</li>
			<li class="next-link noscript">
				 			</li>
		</noscript>
		<li class="show-more next-link">
					</li>
	</ul>
</nav>

							</div>
		</div>

		
		
	</div>
	</div>
</div>

		<footer class="article-footer">
		<div class="container">
	<div class="related-content">
			<div class="tags">
				Tags: <a href="http://www.vh1.com/news/series/martha-snoops-potluck-dinner-party/">Martha &amp; Snoop's Potluck Dinner Party</a>			</div>
						
<div class="VMNRelatedContent related" data-relation-params="{&quot;mtvn_plugin&quot;:&quot;VMNRelatedContent&quot;,&quot;mtvn_action&quot;:&quot;related&quot;,&quot;to&quot;:336057,&quot;limit&quot;:3,&quot;relations&quot;:&quot;all&quot;,&quot;title&quot;:&quot;View related posts&quot;,&quot;minimun&quot;:2,&quot;display_type&quot;:&quot;post&quot;}">
	<a href="http://www.vh1.com/news/index.php?mtvn_plugin=VMNRelatedContent&amp;mtvn_action=related&amp;to=336057&amp;limit=3&amp;relations=all&amp;title=View+related+posts&amp;minimun=2&amp;display_type=post">View related posts</a>
</div>
	</div>
		<div id="zergnet-recs">
		<div class="wrap">
	<script language="javascript" type="text/javascript">
	(function() {
	var zergnet = document.createElement("script");
	zergnet.type = "text/javascript"; zergnet.async = true;
	zergnet.src = "http://www.zergnet.com/zerg.js?id=57216";
	var znscr = document.getElementsByTagName("script")[0];
	znscr.parentNode.insertBefore(zergnet, znscr);
	})();
	</script>
<!-- BEGIN ZERGNET EXTERNAL -->
	<div id="vmnabtest-outer">
		<div class="zergnet" data-report="zergnetext" data-site="vh1news">
			<div style="padding-bottom:10px;" class="header h-wrap group">
				<span>around the web</span>
			</div>
			<div class="zergsitename" style="color:#aaa;font-size:10px;padding-top:3px; float:right; margin-top:-25px;">Powered By Zergnet</div>
			<div id="zergnet-widget-57216" class="clearfix">
				<a href="http://www.zergnet.com/?w=57216" target="_blank"><b>ZergNet</b></a>
			</div>
		</div>
	</div>
<!-- END ZERGNET EXTERNAL -->
</div>
	</div>
		<div class="latest-news"></div>
</div>
	</footer>
	
	<div class="contain-to-grid fixed">
	<div class="sub-footer">
		<a href="http://www.vh1.com"><span class="icon-logo-mtv icon-logo-brand"></span></a>
		<span class="about sitename">VH1</span>

					<span class="about"><a href="http://www.vh1.com/news/about/">about</a></span>
		
		
	</div>

	
<div id="t1_lc_promo1" data-zone="t1_lc_promo1" class="module ent_m006" data-tfstatic="true" data-tffeed="http://www.vh1.com/feeds/ent_m006_vh1/V1_0_1/cee1668b-b170-4a70-a96e-46a007759291" data-tflibs="ENT_M006_VH1" data-tfdriver="ent_m006_vh1_V1_0_1"   style="display:block;">

			<ul class="list">
							<li class="list_item">
					<a href="http://www.vh1.com/legal/frequently-asked-questions" target="_blank" title="FAQ/Help" class="faq_help">FAQ/Help</a>
				</li>
							<li class="list_item">
					<a href="http://www.viacomcareers.com/" target="_blank" title="Jobs" class="jobs">Jobs</a>
				</li>
							<li class="list_item">
					<a href="http://www.vh1.com/legal/terms" target="_blank" title="Terms of Use [Updated 3/14/2017]" class="terms_of_use__updated_3_14_2017_">Terms of Use [Updated 3/14/2017]</a>
				</li>
							<li class="list_item">
					<a href="http://www.vh1.com/legal/privacy" target="_blank" title="Privacy Policy/Privacy Rights [Updated 6/22/2017]" class="privacy_policy_privacy_rights__updated_6_22_2017_">Privacy Policy/Privacy Rights [Updated 6/22/2017]</a>
				</li>
							<li class="list_item">
					<a href="http://www.vh1.com/legal/copyright" target="_blank" title="Copyright" class="copyright">Copyright</a>
				</li>
							<li class="list_item">
					<a href="http://mainevents.mtvn.com/accessibility/" target="_blank" title="Closed Captioning" class="closed_captioning">Closed Captioning</a>
				</li>
							<li class="list_item">
					<a href="http://losangeles.eventful.com/events" target="_blank" title="Eventful" class="eventful">Eventful</a>
				</li>
							<li class="list_item">
					<a href="http://www.vh1.com/partners/tribes/" target="_blank" title="Partners" class="partners">Partners</a>
				</li>
							<li class="list_item">
					<a href="http://srp.viacom.com/sitefaq.html" target="_blank" title="Ad Partners" class="ad_partners">Ad Partners</a>
				</li>
					</ul>
			<ul class="list">
							<li class="list_item">
					<a href="http://www.facebook.com/VH1" target="_blank" title="facebook" class="facebook">facebook</a>
				</li>
							<li class="list_item">
					<a href="https://twitter.com/VH1" target="_blank" title="Twitter" class="twitter">Twitter</a>
				</li>
							<li class="list_item">
					<a href="http://vh1.tumblr.com/" target="_blank" title="Tumblr" class="tumblr">Tumblr</a>
				</li>
							<li class="list_item">
					<a href="http://instagram.com/vh1" target="_blank" title="Instagram" class="instagram">Instagram</a>
				</li>
							<li class="list_item">
					<a href="http://exodus.vh1.com/site/signup" target="_blank" title="Newsletter" class="newsletter">Newsletter</a>
				</li>
					</ul>
		
	<div class="logo"></div><p class="copyright">&#169; 2017 Viacom International Inc. All Rights Reserved. VH1 and all related titles and logos are trademarks of Viacom International Inc.</p>

</div>


</div>

<div id="3" class="vmn_coda_ad vmn_coda_ad-6x6 " data-ad-sizes="6x6" data-ad-keyvalues="" style="padding:0; ">

	
	<noscript>
			</noscript>

</div>


<div id="4" class="vmn_coda_ad vmn_coda_ad-1x2 " data-ad-sizes="1x2" data-ad-keyvalues="" style="padding:0; ">

	
	<noscript>
			</noscript>

</div>


<div id="5" class="vmn_coda_ad vmn_coda_ad-3x3 " data-ad-sizes="3x3" data-ad-keyvalues="" style="padding:0; ">

	
	<noscript>
			</noscript>

</div>



	<div id="mtvn_wordpress_core_templates">
	</div>
<script>
//Toggle auto-firing of ads, ensuring namespaces have been defined without overwriting them.
if (typeof MTVN == "undefined") MTVN = {};
if (typeof MTVN.config == "undefined") MTVN.config = {};
if (typeof MTVN.config.btg == "undefined") MTVN.config.btg = {};
if (typeof MTVN.config.btg.DoubleClick == "undefined") MTVN.config.btg.DoubleClick = {};

MTVN.config.btg.DoubleClick.auto = false;
MTVN.config.btg.DoubleClick.onDemand = true;

</script>
<script type="text/javascript">
var vmn_page_data = { "metadata": {"property":"vh1","hub":"news","is_main":false}, "mappings": {"ad-unit": {"1":"vh1","2":"news"}, "key-values": "", "exclusion-categories": "blogs"}, "settings": {"reload_interval":60000,"reload":true,"autoRefreshByVisibility":true} };
</script>
<script type='text/javascript' src='http://www.vh1.com/news//wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news//wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/MTVWordPressCore/js/core.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/VMNLazyLoad/js/jquery.inview.min.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/VMNLazyLoad/js/VMNLazyLoad.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/themes/news-2014/library/js/scripts.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/themes/news-2014/library/js/jquery.hcsticky.min.js'></script>
<script type='text/javascript' src='http://media.mtvnservices.com/player/api/2.11.7/api.min.js'></script>
<script type='text/javascript' src='https://btg.mtvnservices.com/aria/bentojs.js?site=vh1viral&#038;v=1.13.1&#038;stage=1'></script>
<script type='text/javascript' src='http://btg.mtvnservices.com/aria/coda.html?site=vh1.com&#038;stage=0&#038;v=3.22'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/VMNCodaConductor/js/VMNCodaConductor.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var aocore_settings = {"story_offset":"0","stories_per_page":"5","max_scroll_loads":"5","display_tile_ad":"1"};
var mtvn_ajax = {"startPage":"1","maxPages":"0","nextLink":"","archiveDate":"2017\/12\/01"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/AOCore/js/frontend.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news//wp-includes/js/underscore.min.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news//wp-includes/js/backbone.min.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/AOFlipbookViewer/js/DOMDiscoveryAgent.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/AOFlipbookViewer/js/dragend.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/webcomponents/AOFlipbookViewer/js/component.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/AOFlipbookViewer/vendor/js/detect_swipe/jquery.detect_swipe.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/GEGNav/js/GEGNav.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/MTVNMediaPlayer/js/media_player.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/VH1News/js/aosocial_bundle.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/themes/Helix/library/js/libs/modernizr.custom.min.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/AOCore/js/disruptive_campaign/vendor/vex.combined.min.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/AOCore/js/disruptive_campaign/disruptive.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/VH1News/js/frontend.js'></script>
<script type='text/javascript' src='http://www.vh1.com/news//wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var vmn_chartbeat_config = {"uid":"37728","api_key":"1b42050c1a46dac8186b19e70f775e15","domain":"vh1.com","section":"news,shows","author":"Andrea Wurzburger"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.vh1.com/news/wp-content/plugins/VMNChartbeat/js/config.js'></script>
<script id="dsrpt-cpgn-tpl" type="text/markup-template" charset="utf-8">

	<div class="dsrpt-cpgn">

	</div>

</script>
<script type="text/javascript">

	(function(VMNCodaConductor) {
		VMNCodaConductor.registerPreInitCallback(function() {
			var click_events = [{
	"selector":"body.home #main article.post .item",
	"params" :{
		"type": "internal",
		"callback" : postClickCallback
	}
},
{
	"selector": "body.home #main .trending-list .item",
	"params" : {
		"type"     : "internal",
		"callback" : function(evt, target) {
			var $container = $(target).closest('.interstitial');
			var category = $container.children("h2").text().replace("trending in ", "").replace(/\s+/g, "-").toLowerCase();
			var position = $(target).closest(".row").prevAll().length + 1;
			return "NewsFeed:trending:"+category+":"+position;
		}
	}
},
{
	"selector": "aside.sidebar .trending-list .item",
	"params" : {
		"type"     : "internal",
		"callback" : function(evt, target) {
			var position       = $(target).closest(".row").prevAll().length + 1;
			var label          = "";
			var category_label = "";
			var section_label  = "";

			if ($("body").hasClass("home"))
			{
				section_label = "NewsMain:";
			}
			else if ($("body").hasClass("single"))
			{
				section_label = "NewsArticle:";
			}
			else if ($("body").hasClass("category"))
			{
				section_label = "NewsCategory:";
			}

			if ($(target).hasClass("category") || $(target).parent().hasClass("category"))
			{
				category_label = $(target).text()+":";
			}

			label = section_label+"trending:"+category_label+position;
			return label;
		}
	}
},
{
	"selector":"body.category #main article.post .item",
	"params" :{
		"type": "internal",
		"callback" : postClickCallback
	}
},
{
	"selector":"body.category nav.wp-prev-next",
	"params" :{
		"type": "internal",
		"callback" : function(evt, target) {
			return 'CategoryFeed:show_more_stories';
		}
	}
},
{
	"selector":"body.home nav.wp-prev-next",
	"params" :{
		"type": "internal",
		"callback" : function(evt, target) {
			return 'NewsFeed:show_more_stories';
		}
	}
},

];

var i;
for (i = 0; i < click_events.length; i++)
{
	com.mtvn.wordpress.plugins.VMNCodaConductor.registerClickEvent(click_events[i]);
}

function postClickCallback (evt, target)
{
	//it's a category click
	if ($(target).closest(".category").length > 0)
	{
		return "NewsFeed:"+$(target).text();
	}
	else
	{
		//finding the main post container.
		var $post  = $(target).closest("article").parent();
		var $media = $post.find(".item");

		var position;
		//we calculate the relative position of the post, within its group.
		var relative_position = parseInt($post.attr("class").match(/post-\d+/)[0].replace('post-', ''), 10);

		//if it was loaded dynamically by ajax, we calculate how many post were before and add the relative position.
		var ajax_classes = $post.parent().attr("class").match(/mtvn-ajax-placeholder-\d+/);
		if (ajax_classes !== null)
		{
			var post_per_page = $post.parent().parent().children(".post").length;
			var ajax_count = parseInt(ajax_classes[0].replace('mtvn-ajax-placeholder-', ''), 10);
			position = (ajax_count - 1) * post_per_page + relative_position;
		}
		else
		{
			position = relative_position;
		}

		//selectiong the size
		var size = getSize($media);

		if ($("body").hasClass("home"))
		{
			section = "NewsFeed:";
		}
		else
		{
			section = "CategoryFeed:";
		}

		return section+position+":"+size;
	}
}

function getSize($media)
{
	var size;

	if ($media.hasClass("item-md"))
	{
		size = "medium";
	}
	else if ($media.hasClass("item-sm"))
	{
		size = "small";
	}
	else if ($media.hasClass("item-lg"))
	{
		size = "large";
	}
	else if ($media.hasClass("postcard-left") || $media.hasClass("postcard-right"))
	{
		size = "small";
	}

	return size;
}
		});

		VMNCodaConductor.registerPostInitCallback(function() {
			com.mtvn.wordpress.plugins.VMNCodaConductor.keyValues = {"content_type":"blogs","article_id":"336057"}		});
	})(com.mtvn.wordpress.plugins.VMNCodaConductor);

</script>

<script type="text/javascript" charset="utf-8">
	(function($) {
		$.extend(true, com.mtvn.wordpress.plugins.VMNCodaConductor.reporting.page_params, {"omniture":[{"nice_name":"blog-categories","value":"Shows"},{"nice_name":"news-story","value":"You Need to Hear the Mariachi Version of \"Gin and Juice\" in This Martha & Snoop Bonus Clip [Shows]"},{"nice_name":"story-date","value":"12.01.2017"},{"nice_name":"author","value":"Andrea Wurzburger"},{"nice_name":"page-type","value":"news article"},{"nice_name":"site-section","value":"news"},{"nice_name":"hier2","value":"news\/336057\/martha-snoop-gin-and-juice-bonus-clip"},{"nice_name":"events","value":"event18"},{"nice_name":"prop12","value":"shows"}]});	})(jQuery);
</script>
<script type="text/javascript" charset="utf-8">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</script>
	</div>
	<!-- PAGEOK -->
	</body>
</html>
		
	